This topic contains 4 replies, has 2 voices, and was last updated by  eckelmann 2 years ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #590

    eckelmann
    Participant

    In my contact form I always get form fields with the hight of one row. For the text area field I would like to change it to several rows. The documentation of contact form 7 gives the ability for (cols)x(rows). In a standard word press theme it works but how can I recieve this under the corporate pro theme?

    Thanks and regards

    Johannes

    #603

    eVision Themes
    Keymaster

    Hi,
    Make sure the generated shortcode for textarea looks something like this :
    [textarea your-message 40×10 “your message here …”]
    This should work with the design.

    Thanks

    #606

    eckelmann
    Participant

    Hi,
    thanks for your reply. Unfortunately I can’t implement it under the corporate pro theme. The contact form always looks like that:
    http://eulefilm.de/media/corporate%20pro%20theme.png

    When I change the theme I get the larger text area field and it looks like that:
    http://eulefilm.de/media/standard%20theme.png

    This is the code I am using:
    <p>[text* your-name placeholder “Ihr Name”] </p>
    <p>[email* your-email placeholder “Ihre Email-Adresse”] </p>
    <p>[text* your-subject placeholder “Betreff”] </p>
    <p>[textarea* your-message 40×10 placeholder “Ihre Nachricht”] </p>
    <p>[submit “Nachricht senden”]</p>

    Thanks

    #608

    eVision Themes
    Keymaster

    Textarea row height seems overriden by theme CSS preventing it to take actual rows height. So this can be fix by adding simple custom CSS. Follow the steps below:

    1. First you need to Go to your Dashboard -> Appearance -> Customize -> Theme Options -> Custom CSS options.
    2. In this section you need to add this CSS:
    .wpcf7-form-control {
    height: auto;
    }

    You can adjust no. of rows from CF7 shortcode.

    Write us if problem exists.

    #612

    eckelmann
    Participant

    Great, that’s it! Thanks a lot.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.